SIEMENS-SL45.NET .:: Глобальный хелп OFF-LINE ver. 4::.

Глобальный хелп по телефону SIEMENS SL45 / Восстановление Адресной книги

Автор статьи - Николай aka Goblin (goblin@oslik.ru)

Вариант № 1

Вам понадобится мидлет Ab Tools

Копируем мидлет в телефон (на карту). Запускаем, и выбираем нужный пункт, для нашего случая нужен пункт "Repair" и нажимаем ОК, ждём окончания процедуры. После чего вытаскиваем карту и выключаем телефон. Дожидаемся окончания выключения телефона и ставим карту обратно в телефон, и включаем телефон.

После того как телефон включится, пробуем войти в адрессную книгу...Телефон пишет "идёт чтение адрессной книге" Оставляем телефон в таком положении минут ~10-15 Потом пробуем войти. Если все таки не зашли туда, выключите и включите телефон. Ваша адресная книга восстановлена!!!

Вариант № 2

Вам понадобится программа 5F02 Converter

Если не получилось мидлетом, то переходим ко второй проге. Она вытаскивает инфу из файла *.adr Возможно, Вам зачем либо пришлось умертвить свой Адресбук в телефоне, но по чудесной случайности файлы Адресбука (*.adr) Вы перед этим сохранили у себя на диске (на компе). Эта программа - читалка файлов 5F02.ADR (для S/ME45) и 5F03.ADR (для S/ME45 и конечно же SL45 ). Умеет сохранять прочтенные данные в текстовом файле (просто так, на всякий случай) и в файле формата *.CSV, который затем без труда грузится в Аутлук, а оттуда - через Квиксинк - в телефон.

Удачи!

Перепечатка материалов разрешается, только после письменного разрешения администратора сайта (e-mail).
При перепечатке любого материала видимая ссылка на источник www.siemens-sl45.net обязательна.
© Copyright SIEMENS-SL45.NET 2004


Глобальный хелп / Полезные советы по работе аккумулятора

Автор статьи - Ваха (baxa-m@yandex.ru)

Вопросов насчет аккумулятора на форуме много, вот решил поделиться своим наблюдением. Может быть мой опыт кому-нибудь поможет.

С недавних пор заметил, что мой стандартный аккумулятор стал быстро разряжаться. Раньше, при условии ПОСТОЯННОГО использования жавы и мр3, его хватало на целый день (не удивляйтесь, бывали такие дни когда я только приобрел Ослика и не мог наиграться). Теперь же "умирать" стал за пол дня. Ну, думаю, пора покупать новый. Пока собирал деньги взял у друга попробовать новый аккумулятор.

Велико же было мое удивление когда и его аккумулятор прожил на моем Ослике столько же. Оп-па! Приплыли! Значит дело не в аккумуляторе. Что-то я накалбасил.

Патчи? Залил родную прошивку без патчей - тот же результат. Может сбилась настройка зарядки? Попробовал откалибровать - результата не добился, зато Ослик по окончании зарядки стал вырубаться. Только LS2 переходит на LS3 при зарядке (в Нетмониторе), тело выключается. Вернул обратно. Что-же? Мучался этим вопросом долго. Помог случай.

У меня давно плохо работала кнопка 0, никак не доходили руки разобрать корпус и почистить контакты. Наконец собрался, разобрал корпус, помыл внутри спиртом контакты кнопок, и заодно все другие контакты: антенны, вибромотора, наушника, микрофона, СИМки, флэшки и аккумулятора. Кстати мусора там накопилось предостаточно, наверное из-за китайского корпуса.

После этого аккумулятор стал держать как новый!!! ВСЯ ПРИЧИНА ЗАКЛЮЧАЛАСЬ В ЗАГРЯЗНЕНИИ КОНТАКТОВ!!!

НУЖНО ПЕРИОДИЧЕСКИ ВСКРЫВАТЬ КОРПУС, особенно китайский И ЧИСТИТЬ ЛЮБИМОГО ОСЛИКА!!!


Глобальный хелп / Бэкап и заливка фуллфлеша

Автор статьи - Franky (franky@siemens-sl45.net)

Бэкап фуллфлеша очень важная процедура при пользовании телефона, на который время от времени ставятся патчи. В случае «падения» телефона вы сможете вернуть телефон в рабочее состояние «залив» свой фуллфлеш в телефон. Но вам стоит помнить, что залить бэкап в телефон в том случае если телефон определяется программами, иначе вам придется бежать в сервисный центр Siemens. Только там вам смогут помочь.

Для данной операции я использую программку V_Klay. На данный момент, конечно, существует и другие программы. Но главная особенность V_Klay то, что он работает на операционных системах Windows 9x/Me/NT/XP. А также без проблем работает как с COM, так и USB шнурами для подключения к телефону. Программку можно всегда скачать на сайте vi-soft.com.ua.

Итак, перейдем непосредственно к процедуре бэкапа.

Подготовка

Прежде всего, вам нужно правильно указать модель телефона, с которым вы будете работать. Нажимаем на галочку и выбираем в выпавшем окошке SL45. Потом выберите порт, на котором «висит» ваш дата-кабель и скорость для порта. Для COM – 115200, для USB можете выставить максимум (460800).

Теперь нажимаем кнопку обновить. На экране побежал бегунок.

Бэкап и заливка фуллфлеша

Выключаем телефон и вставляем его в стакан или подключаем к USB кабелю. Если вы правильно сделаете настройки, то телефон соединится и около кнопки «Обновить» появится надписи с информацией о телефоне и флеше.

Бэкап и заливка фуллфлеша

Наконец переходим к вкладке Флешер. Там у нас такая вот картина.

Бэкап и заливка фуллфлеша
Чтение памяти – считывание памяти в буфер, а после
Сохранить Файл… - сохранятся ваш бэкап на диск

Открыть Файл – открывает файл с диска а после
Запись памяти – записывает ваш бэкап в телефон

По умолчанию в програмке стоят настройки для считывания фуллфлеша. Адрес: 0x000000 (fullflash) и Размер: 0x600000 (fullflash).

Бэкап

Как только вы нажмете кнопку, Чтение памяти появится бегунок, в котором отобразится состояние считывания. А завершится операция таким вот диалогом.

Бэкап и заливка фуллфлеша

Теперь нажимаем Сохранить Файл… и выбираем место и имя на диске. Но я рекомендую сохранять FullFlash и EEprom отдельно, для этого нужно в разделе Память телефона выбрать Адрес: 0x5F0000 (eeprom) и Размер: 0x010000 (eeprom). Поэтому проделайте операцию с такими же настройками.

Заливка фуллфлеша

Если же вам нужно загрузить бэкап в телефон порядок действий такой Открыть Файл там выберите файл с сохраненный флешем и нажмете Запись памяти.

После записи памяти в телефон вам придется достать и вставить обратно аккумулятор телефона или нажать кнопку Включить рядом с окошком выбора скорости COM порта.


Глобальный хелп / Калибровка аккумулятора

Автор статьи - Ribez

Для чего нужна калибровка? Калибровка нужна в том случае, если ваш аппарат работает всего несколько часов, бывали случаи что до 4-6 часов в сутки, очень быстро разряжается т.е. пишет, что аккумулятор разряжен и срочно требуется подзарядка, индикатор батареи работает некорректно и т.п. Вот тогда то мы и будем возвращать его к нормальной жизни.

Для начала пара правил:

  1. Если вы сливаете EEPROM или FULLFLASH, то делайте это при полностью заряженном аккумуляторе, или на крайний случай напишите при сохранении EEPROM или FULLFLASH в имени файла значение напряжения перед сливанием. Тогда следующий раз заливать обратно нужно будет именно при том напряжении аккумулятора. В этом случае у вас точно не слетит настройка аккумулятора и вам его не придется заново калибровать.
  2. Обязательно сделайте Baсkup перед началом работы.
  3. Прочтите все до конца, прежде чем что-то делать.

Для работы нам потребуются:

  1. Включенный NetMonitor
  2. Два тонких проводка
  3. Вольтметр (желательно цифровой)
  4. Программа V_Klay
  5. Программа Siemens Tool 1.3

После того как инженерное меню активировано, нужно зайти в него, для этого жмем только правую качель (джойстиком не сработает), далее #, выбираем в меню пункт "Конфигурация" и устанавливаем в нем значение "Charge", остальные пункты лучше не трогать. Если этого не сделать, то Вы долго и упорно будете искать меню изображенное ниже. Выходим в главное меню Net Monitora и жмем 1 - включается режим Serving Cell (в режиме ожидания), теперь можно нажать любую цифровую клавишу и мы оказываемся в режиме Charge monitor где:

VBxxxx - напряжение на аккумуляторе в милливольтах.
EXхх - при работе
EX04 - ближе к концу зарадки после отключения сетевого стало 12(13)
EX00 - после выключения телефона
LS - состояние зарядки (0 - нет, 1 - быстрая, 2 - нормальная, 3 - пониженная, 4 или 5 - батарея заряжена).

  • LS0 - рабочий режим телефона - зарядное устройство не подключено.
  • LS1 - капельный заряд
  • LS2 - заряд номинальным током (SB100 ед., при превышении VBxxxx UMAXxxxx срабатывает термисторный предохранитель - тогда SB001 ед., EX4)
  • LS3-заряд уменьшенным током (SB085 ед.---SB001 ед., индикатор батареи на дисплее полный, EX13)
  • LS4 - окончание заряда (отключение зарядного устройства, обнуление LT00000, SB000, EX12)
  • LS5 - рабочий режим телефона с подзарядом - зарядное устройство подключено ( EX12 , LT считает с 00000, аккумулятор периодически подзаряжается током SB085 ед., т.е. идет поддержка VBxxxx = UMAXxxxx )
TB - температура батареи в градусах Цельсия, умноженная на 10.
TE - температура окружающей среды (аппарата) в тех же единицах.
mA - текущий ток заряда/потребления.
AT - тип батареи (1 - NiMH, 3 - Li-Ion).

Идем дальше. Отсоединяем аккумулятор и подсоединяем два тонких проводка на крайние клеммы телефона, куда подходит питание от батареи. Я для этого взял старый провод от наушников с плеера, снял изоляцию, а внутренний тонкие проводки подсоединил. Теперь ставим батарею на место и проверяем напряжение на тестере, если все ОК, то идем дальше, если же на тестере ничего нет, значит проверяем контакты (либо меняем сам тестер) Делаем Backup!!!

Следующий этап, устанавливаем программу SiemensTool 1.3 Дальше есть два режима работы этой программы (вернее их три, но со вторым я не разобрался).

1 РЕЖИМ

В файле siemenstool.ini находим:
; 1 - ServiceMode
; 2 - BurnInMode
; 3 - BFBMode
WorkMode=1 (здесь мы устанавливаем режим 1 )

Подсоединяем кабель к телефону или стакан(синхронизирующая станция). Здесь кому что больше нравиться, я использую кабель для прошивки от х35 модели, он практически универсальный и подходит почти ко всем моделям Siemens. Тем более калибровка у меня навернулась я думаю, скорее всего из-за стакана. Включение и выключение зарядки в телефоне видно плохо сказывается на нем. Поэтому если есть возможность, то лучше купить отдельно COM кабель и жить спокойно.

Разряжаем аккумулятор т.е. доводим его до состояния - "Аккумулятор разряжен, требуется подзарядка". После этого включаем, или пытаемся включить телефон и сразу же переходим в режим NetMonitor , смотрим на значение AS и записываем его на бумажке.

Если у вас стоит первый режим, то запускаем программу SiemensTool 1.3 и сразу же жмем коротко но ясно красную кнопку включения/выключения на вашем телефоне. Это касается, если вы пользуетесь простым кабелем, если же у вас стакан, то вместо нажатия на кнопку (и дергания телефона из стакана) нужно, в самом начале отключить питание от стакана (отсоединить штекер питания), а потом в момент нажатия кнопку вставить штекер питания в стакан.

Если все прошло удачно, то загорится надпись READY, и в окошках появятся цифры. Цифры появятся только в ячейках, так как программа рассчитана на х35 модели и не показывает текущие значения напряжения, температуры и т.п.

3 РЕЖИМ

Если у вас ничего не вышло, то включаете в siemenstool.ini файле 3 режим:
; 1 - ServiceMode
; 2 - BurnInMode
; 3 - BFBMode
WorkMode=3 (здесь мы устанавливаем режим 3 )

Тогда вам будет достаточно просто включить телефон. Этот режим еще хорош тем, что можно сразу включить на телефоне NetMonitor и сравнить его показания с показаниями вольтметра, но он годится только при заряженном аккумуляторе, т.к. в при разряженном телефон естественно не включится.

Теперь разберемся с ячейками. Их всего 14, 10 из них пронумерованы и находятся отдельно, 4 ячейки принадлежат калькулятору. Нам пока нам нужны только верхние четыре ячейки: 0000, 0002, 0004, 0006
0000: указывается минимальное напряжение аккумулятора (значения изменять при напряжении близком к 3,6V);
0002: указывается напряжение до которого идет заряд аккумулятора (обычно 4200);
0004: указывается максимальное напряжение аккумулятора (значения изменять при напряжении близком к 4,2V);
0006: указывается напряжение при разряженном аккумуляторе.

Перед тем как, вносить изменения, можете сохранить свои настройки, нажав кнопку Write File. Сравниваем напряжение вольтметра и NetMonitor, а именно значение VB. Все показания вольтметра и NetMonitora снимать при ВКЛЮЧЕННОМ ТЕЛЕФОНЕ И ПОДСОЕДИНЕННЫХ ПРОВОДКОВ К БАТАРЕЕ!!! Опять все записываем, чтобы не забыть и не запутаться.

Если значение AS, которое Вы записали в самом начале, больше 3650, то сначала нужно откорректировать его. За этот параметр отвечает ячейка 0006. Уменьшаем его до тех пор, пока NetMonitor не покажет 3650, или меньше (я уменьшил до 3500). Для этого в ячейке 0006 записываем значение на 100-300 единиц меньше, чем было ранее, жмем кнопку WritePhone в правом верхнем углу программы и ВЫКЛЮЧАЕМ ТЕЛЕФОН КРАСНОЙ КНОПКОЙ. Это делается для того. чтобы телефон принял новые значения (типа перезагрузки виндов, только он не пишет - подождите идет обновление системы.Чем меньше значение в этой ячейке, тем дольше будет происходить разряд (в поем примере он должен идти до 3,5 вольт). Кого устраивает долгая работа телефона и ему плевать на индикатор, то можно в принципе уменьшить значение 0006 до 200-300 единиц и на этом закончить. Аккумулятор будет разряжаться на всю катушку, у меня к примеру при значении 109 (при работе Java) он разряжался до 2,7 вольт. Но такой режим не очень хорош для здоровья аккумулятора. При таких низких значениях ячейки 0006, значения NetMonitora практически не изменяются, поэтому индикатор батареи работать не будет, и все время будет показывать полную зарядку, телефон также будет отключаться без всякого предупреждения.

Для нормальной работы индикатора, нужно теперь сравнить напряжение записанные на вашем листке (VB). Если значения NetMonitora (VB) больше значения вольтметра, уменьшаем (если значения NetMonitora (VB)меньше - то увеличиваем) значение в ячейке 0000 на 100-300 единиц (подбирается опытным путем). Если значения вольтметра и NetMonitora сильно разняться, к примеру в 2-3 десятых вольта, то уменьшаем (увеличиваем) на 200-300 единиц, если отличаются на сотые доли, то на 50-100.

После того как вы добьетесь одинаковых показаний вольтметра и NetMonitora (значение VB), то переходим к следующему пункту.

Если в процессе перезаписи значений возникла ошибка, что-то вроде ошибки записи в блок 67, то придется переписывать EEPROM, если не поможет, то заливаем обратно FULLFLASH.

Заряжаем аккумулятор и делаем Backup!!!

Снимаем напряжение вольтметра и NetMonitora (значение VB). Все показания вольтметра и NetMonitora снимать при ВКЛЮЧЕННОМ ТЕЛЕФОНЕ И ПОДСОЕДИНЕННЫХ ПРОВОДКОВ К БАТАРЕЕ!!!! Записываем показания. Если значения NetMonitora (VB) больше значения вольтметра, уменьшаем (если значения NetMonitora (VB)меньше - то увеличиваем) значение в ячейке 0004 на 100-300 единиц (подбирается опытным путем. После того как вы добьетесь одинаковых показаний вольтметра и NetMonitora (значение VB), то переходим к следующему пункту.

Если в процессе перезаписи значений произошел сбой с 67 блок, то восстанавливаем телефон как было описано выше.

После этих операций телефон должен нормально, ну или намного лучше чем раньше работать. Для более лучшего результата, нужно провести все работы по корректировке значений еще два-три раза, начиная с выставления значения AS в ячейке 0006, если же оно приемлемо, то корректируются только ячейки 0000 и 0004.

Заключение

Можете еще поработать с калькулятором. Для этого, нужно снять значения с NetMonitora при разряженном аккумуляторе и при полном заряде, а также соответственно значения по вольтметру. Далее вводите значения как приведено ниже:

  • Vbatt1 - значение по вольтметру при разряженном аккумуляторе;
  • VBattDSP1 - значение по NetMonitora (значение VB) при разряженном аккумуляторе;
  • Vbatt2 - значение по вольтметру при заряженном аккумуляторе;
  • VBattDSP2 - значение по NetMonitora (значение VB) при заряженном аккумуляторе.
и нажимаете кнопку "CalculateSpgY03V SpgY04V", что приводит к изменению значений в полях:,
SpgY03V - т.е. 0000
SpgY04V - т.е. 0004

Мои текущие значения: 0000: 4176 min акум
0002: 4247 max акум
0004: 63774
0006: 730
0008: 65535 не меняется на всех сликах
000А: 65535 не меняется на всех сликах
000С: 101
000Е: 65225
0010: 65535 не меняется на всех сликах
0012: 65535 не меняется на всех сликах


Глобальный хелп / "Секретные" сочетания клавиш

*#06# (IMEI) показывает серийный номер любого телефона GSM , если затем нажать на левую клавишу прокрутки, то будет показан номер версии прошивки (в некоторых телефонах нужно нажать правую клавишу).

*#0606# затем нажать на левую клавишу прокрутки - покажет наличие блокировок. Внимание!: СИМ-карта должна быть вытащена.

*#0001# затем зеленую трубу - устанавливается английский язык меню. Установки на СИМ-карте не меняются.

*#0007# затем зеленую трубу - устанавливается русский язык меню, установки на СИМ-карте не меняются.

*#0000# затем зеленую трубу - автоматический выбирается язык, к которому относиться СИМ-карта, чаще всего - английский.

*#9999# затем зеленую трубу - сбрасывает параметры телефона к заводским. Установки на СИМ-карте не меняются.


Глобальный хелп / Замена картинок с помощью FFmod

Для начала вам стоит сделать бэкап вашего фуллфлеша. Т.к. он вам понадобится в дальнейшем при работе в FFmod. Запускаем программу и нажимаем надпись Load в верхнем левом углу и выбираем свой сохраненный фуллфлеш. Теперь в правом верхнем углу нам нужно в поле ffmod Function перейти на вкладку Image.

Замена картинок с помощью FFmod

ID – номер рисунка в HEX формате
Adress – адрес рисунка в памяти фуллфлеша.
ImgSize – размер рисунка в пикселях
Bytes – размер рисунка в байтах.
#117 – номер рисунка в обычном формате, именно его используют все авторы графики когда пишут текст вида «анимация при отправке SMS, поменяйте рисунки с помощью FFmod с 12-14» или «после применения патча поменяйте рисунки в вашем флеше с 12-14»
Предосмотр – здесь отображается рисунок под номеро xxx, где xxx это номер рисунка в строке #xxx

Нажав правую кнопку по рисунку в окне предосмотра или по определенному файлу в списке, который левее окна предосмотра, выскакивает такое вот окно:

Copy Original to Clipboard >> Сохранить выбранный файл в буфер обмена
Paste Clipboard to New >> Загрузить в окно «Нового файла» файл с буфера обмена
Delete new Image >> Убрать рисунок вставленный в окно «нового файла»
Load New From File >> Загрузить в окно «Нового файла» файл с диска
Save original to File >> Сохранить выбранный файл на диск в формате bmp
Save All original to files >> Сохранить все файлы на диск в формате bmp

Замена картинок с помощью FFmod

Нужно изменить рисунок. Тогда выбираем его, сохраняем на диск, открываем редактор, изменяем файл, вставляем в окно «Нового файла». Теперь как же это все сохранить в телефон? Очень просто! Нажимаем кнопку Save и вводим имя измененного флеша, например newff после этого FFmod задаст вопрос «Create Partial Flash files?» на который отвечаем «Yes».

Замена картинок с помощью FFmod

После этого получаем файлы newff.bin и те Partial файлы: newff_1F.bin, newff_4A.bin и newff_4B.bin. Использовать файлы newff.bin, newff_1F.bin не стоит, а вот два остальных нужно загрузить во флеш телефона через программку V_Klay. Но в ней нужно сделать следующие установки:
Адрес - 0x4A0000
Размер - 0x010000
Теперь в вашем телефоне графика будет изменена


Глобальный хелп / Форматирование MMC после смены прошивки

После смены прошивки остается заполнить вашу карту памяти стандартными папками, так называемый content. Его можно найти здесь

Перейдем к форматированию карты. Для этого понадобится Data Exhange Software, который как раз и позволяет просматривать содержимое карты MMC через дата-кабель. Его еще часто называют DES. Установив программку, заходим в Мой компьютер и нажимаем правую кнопку по диску Mobile. Выбираем пункт Format далее Start. Форматирование продлится около 30 сек.

Форматирование MMC после смены прошивки

Данную операцию можно проделать и без Data Exhange Software, но для этого у вас должен быть MMC Card-Reader.

После завершения форматирования необходимо скопировать MMC Content на карту памяти.

Если вы хотите сохранить вашу Адресную книгу, зайдите на MMC и откройте доступ к скрытым папкам. Теперь вы увидите папку "Adress Book" скопируйте ее на винчестер, а после форматирования MMC обратно на ММС.


Глобальный хелп / Бэкап и заливка фуллфлеша при помощи FREIA

Автор статьи - Alex

Кроме программы VKlay, для работы с фулфлешем телефона есть ещё одна, не менее удобная программа- FREIA. В перечень ее возможностей входит не только бэкап и заливка фуллфлеша, но и многие другие функции (разлочка, считывание/запись параметров батареи, и т.д.). На момент написания статьи программа умеет работать с телефонами серий x30, x35, x40, x45, x50, x55, x60, SX1.

Бэкап фулфлеша

Прежде чем приступить к бэкапу, необходимо настроить программу для работы с телефоном. Настройка производится в окне "Configuration functions", получаемое при помощи нажатия соответствующей кнопки в главном окне программы.

Бэкап и заливка фуллфлеша при помощи FREIA

Здесь необходимо указать COM-порт, к которому подключен стакан (или дата кабель), и скорость работы. Все остальное рукомендуется оставить как есть. Подтверждаем внесенные изменения кнопкой "Ок".

Далее, в окне "Phone information", в выбираем тип телефона (SL45). Программа покажет адреса Firmware, первого и второго EEprom'a и Bootcor'a (2-й eeprom и bootcore в SL45 отсутствуют).

Бэкап и заливка фуллфлеша при помощи FREIA

После этого выключаем телефон, и в главном окне программы нажимаем кнопку "Read flash from phone".

Бэкап и заливка фуллфлеша при помощи FREIA

Выбираем что именно мы будем сохранять (в нашем случае это Firmware), и нажимаем "Ok". В окне "Process information" видим примерно следующее:

Бэкап и заливка фуллфлеша при помощи FREIA

После появления надписи "Waiting to power on the phone ..." вставляем телефон в стакан, или, в случае с дата-кабелем, быстро нажимаем и отпускаем красную трубку (надо чтобы телефон не включился!).

Дальше ждем окончания процесса. Файл прошивки имеет расширение *.FLS, и сохраняется в папке с программой.

Заливка фуллфлеша

Для заливки фуллфлеша в телефон, необходимо настроить параметры программы (если ранее они небыли настроены). После чего выключить телефон. Нажать кнопку "Write flash to phone". В появившемся диалоге выбрать файл с сохранённым флешем.

Далее, после появления надписи "Waiting to power on the phone ..." в окне "Process information" вставляем телефон в стакан, или, в случае с дата-кабелем, быстро нажимаем и отпускаем красную трубку (надо чтобы телефон не включился!).

После успешного завершения процедуры закрываем программу, и включаем телефон.


Глобальный хелп / Различия прошивок 43 - 56 в телефонах SL42, SL45, SL45i

Автор статьи - Franky (franky@siemens-sl45.net)

Различия прошивок SW 43 -> SW 49

Функция | Описание
Адресная книга | Исправление бага при сортировке и поиске
Батарея | Исправление бага в зарядке Улучшение функции зарядки аккумулятора
MMI | Улучшение функции "Нянька" Новые языки интерфейса, версия 5 4 новых языка интерфейса SMS/архив - исправление бага с надписью во французском языке
JAVA | Исправление бага HTTP Server Socket Исправление бага OTA download Улучшено качество скачивания файлов Добавлено сообщение о недостатке места на карте MMC, при скачивании файлов Ускорение алгоритма распаковки JAR Убрана возможность передачи файлов через IRDA Исправление бага в RMS (Record Management system) Добавлено JAM:Сообщение об удачном скачивании Улучшена функция "открыть" при перемещении файлов Исправление бага в JAM Explorer после просмотра Информации о URL Улучшена функция отправки\приема SMS из Java Исправлены багги в различных функциях JAVA классов
MMC | Исправление бага в файловой системе
Список операторов | Некоторые операторы изменили имя, некоторые добавились: 238 001 "DK TDC" 238 030 "Orange" 246 003 "TELE2" 250 002 "RUS MegaFon" 250 005 "SCS" 250 007 "RUS SMARTS" 268 001 "P VODAFONE" 293 070 "SI VEGA 070" 362 091 "UTS" 404 031 "INA AIRTEL" 502 016 "DiGi" 510 011 "IND - Excelcom" 515 005 "DIGITEL" 520 010 "Orange" 520 099 "Orange" 525 003 "SGP M1-GSM" 525 004 "SGP-M1-3GSM" 607 001 "GAMCEL" 618 001 "LBR Lonestar Cell" 621 040 "NG NITEL" 624 001 "MTN CAM" 722 035 "PORT-HABLE" 214 001 "E VODAFONE" 248 003 "TELE2" 250 004 "SIBCHALLENGE RUS" 340 001 "F ORANGE" 362 051 "Telcell GSM" 410 003 "PK-UFONE" 417 093 "SyriaTel" 603 002 "OTA NET" 647 000 "Orange re"

Различия прошивок SW 49 -> SW 52

Функция | Описание
Адресная книга | Исправление бага при копировании номеров из сим-карты в адресную книгу
Список операторов | Некоторые операторы изменили имя, некоторые добавились: 262 002 "Vodafone D2"
MMI | Новые языки интерфейса а также некоторые исправления Добавлен рисунок для Т9 Изменения в Китайском Лэнгпаке Исправление бага в состовителе мелодий Исправление бага в Греческом Т9
JAVA | Улучшение Java и API функций Исправление бага при скачке приложений

Различия прошивок SW 52 -> SW 54

Функция | Описание
Батарея | Улучшение алгоритма зарядки (увеличивает время работы в режиме ожидания для некоторых типов аккумулятора)
Список операторов | Некоторые операторы изменили имя, некоторые добавились: 724 031 "Oi" 404 068 "Dolphin" 724 002 "TIM" 724 003 "TIM" 724 004 "TIM" 510 011 "proXL" 230 001 "CZ PAEGAS-CZ" -> "T-Mobile CZ"
JAVA | Исправление бага в Java HTTP Исправление бага в JAVA SDK Улучшение в Java editor Ускорение алгоритма JAM explorer Улучшение в JAVA security Исправление бага при скачке приложений
MMI | Новые языки интерфейса, а также некоторые исправления Исправления в хелп файлах Исправление бага в Арабском Т9
MMC | Улучшение алгоритма работы MMC

Различия прошивок SW 55 -> SW 56

Функция | Описание
Список операторов | Некоторые операторы изменили имя, некоторые добавились: PLMN list changed 204 04 “vodafone NL” 262 07 “02 – de” 214 01 “vodafone ES” 268 01 “vodafone P” 604 00 214 09
JAVA | Исправление бага в J2ME CLDC Исправление бага в Java вычислениях (64bit) Исправление бага в Java Game API
MMC | Поддержка карт памяти "Sandisk"
MMI | Исправления в Шведском Лэнгпаке Исправления в польском меню
WAP | Изменения в стандартных подключениях операторов Amena, Movistar, Vodafone (Испания)
........................................................................... ..........................................................................................


Глобальный хелп / Активация Java на SL42/SL45/SL45i

Итак, после перепрошивки вашего телефона у вас не работает Java. В телефонах SL42/SL45/SL45i есть возможность ее включить. Попросту говоря, имея на руках SL42, мы можете превратить его в SL45i, ведь начинка этих телефонов идентична.

Для начала, как обычно, делаем бэкап вашего FullFlash’a и EEPROM’a. Теперь нам необходимо скачать Siemens Quick EEPROM features 3.3

Порядок действий:
1. Запускаем программку и снимаем все галочки кроме пункта «Enable Java Function in upgraded SL4x»
2. Указываем порт на котором сидит ваш оСЛИК
3. Подключаем кабель и выключаем телефон
4. Нажимаем кнопку «Start»
5. В нижнем левом углу появится надпись «Scanning» теперь жмем коротко но ясно красную кнопку включения/выключения на вашем телефоне
6. Когда операция завершится ваш телефон включится сам а внизу экрана появится надпись «ОК»

Активация Java на SL42/SL45/SL45i

После активации Java вы должны забросить свои мидлеты в папку Java/Jam на MMC карте. Запускать мидлеты вы сможете через Меню>Интернет/Игры>Java и только так. Запустить Java приложения через Проводник вы не сможете!!!

Телефон готов к работе!!!


Глобальный хелп / Структура стандартного контента

Я так думаю для вас будет полезным знать, что из себя представляет "Стандартный контент MMC". Не каждый пользователь телефона начального уровня, сможет найти где у него диктофонные записи (если он их хочет конвертировать), где лежат мелодии и т.п.

Address book – в этой папке хранится содержимое адресной книги, по умолчанию эта директория скрыта.
Animation – здесь хранится анимация, которая отображается при загрузке телефона. Внутри также папки, определяющие отдельные анимации. В этих папках 17 фалов: 10 фалов вида On_1,On_2…On_10 их размер 101x80; 7 фалов вида Wait_1, Wait_2 …Wait_7 размер 19x30 отображается во время ожидания.
Bitmap – сюда нужно закидывать логотипы.
Help – помощь к телефону.
Java – внутри этой папки находится еще одна Jam и именно в нее нужно записывать Java мидлеты.
Language – здесь лежат языки интерфейса.
Misc – сюда копируются данные, передаваемые через инфракрасный порт SL45.
Mp3 – здесь лежат файлы для MP3 плеера.
Ringing tone – загружаемые мелодии.
SMS – sms архив.
T9 data base – базы данных T9.
Voice memo – записи диктофона.
Voice notice – Записанные ответы.


<

Глобальный хелп / Включение NetMonitor

Автор статьи - Franky (franky@siemens-sl45.net)

В некоторых моделях мобильных телефонов Siemens имеется недокументированное сервисное меню, которое обычно выключено. Первый пункт этого меню ("Monitor") позволяет войти в режим NetMonitor. Информация хранящаяся в этом меню может быть очень полезна при калибровке аккумулятора и просто для любителей порыться в телефоне.

Cкачиваем программку под названием Siemens Service Code Generator. Она включит NetMonitor даже через инфракрасный порт!!!

1.1 Включение NetMonitor через IRDA

После запуска программы, автоматически загружается окошко с настройками, выбираем пункт "IRDA" и нажимаем "ОК".

После этого окошко с настройками пропадет, и откроется главное меню. Теперь нам нужно активировать на телефоне "IRDA" (Меню >> Настройки >> Инфракр. порт) и ложим телефон вблизи принимающего устройства. Выбираем "Connect"

Если компьютер обнаружил ваш телефон то в следующем окне он появится в списке выбора после чего нажимаем "ОК"

1.2 Включение NetMonitor через COM

После запуска программы, автоматически загружается окошко с настройками, выбираем пункт "Serial Port", указываем номер порта и нажимаем "ОК".

После этого окошко с настройками пропадет, и откроется главное меню. Выбираем "Connect". ТЕЛЕФОН ВЫКЛЮЧАТЬ НЕ НАДО!!!

2. Общая часть

Теперь перед вами откроется окно с информацией о телефоне. Здесь нам стоит обратить внимание на пункт "Level". В нем задается "уровень" NetMonitor'a: первый - полный и второй - ограниченный, рекомендую выбрать Full Service Menu. Выбираем "Activate", после чего вы получите телефон с включенным NetMonitor.

Для завершения активации, вам нужно включить и выключить телефон. В меню NetMonitor можно войти комбинацией клавиш "Меню + *"


Глобальный хелп / Смена прошивки телефона

Прежде чем приступать к смене прошивки телефона обязательно сделайте бэкап фуллфлеша. Выключите хранители экрана и закройте все приложения.

Итак, начнем. Запускаем программку SLIKxxxx.exe и нажимаем кнопку Serial Config. Выбираем порт и скорость, но значение скорости не более 101500, даже если у вас USB кабель он не сможет поменять прошивку на скорости выше 101500. Для надежности можете установить скорость в 57600. Нажимаем ОК.

Теперь вам нужно убедится в том что напротив пунктов Post-check и Pre-check стоят галочки. Выключаем телефон, но не подключаем к телефону, и нажимаем Start. Сразу же вставляем телефон в стакан или подключаем к кабелю. В поле Connect Mobile должен побежать бегунок и перескочить на пункт Transfer UP-SW.

Смена прошивки телефона

Как только бегунок побежит в поле Erase Flash, можете расслабиться на 5-15 минут. После завершения прошивки отключите телефон от кабеля, достаньте и вставьте батарейку.

Смена прошивки телефона

Иногда приложение может привести к «завису компьютера» поэтому отключите телефон от кабеля, прежде чем закрыть приложение. Данный глюк был замечен на OC Windows XP


Глобальный хелп / Обзор телефона SIEMENS SL45

Автор статьи - SHERIF (sherif-sl45i@inbox.lv )

Перетелефон... недокомпьютер... Примерно такие варианты условного обозначения аппарата крутятся в голове автора статьи, смыслом которой является попытка проанализировать и оценить функции такого аппарата, как Siemens SL45. Такова уж природа человека (а автор, как не странно, относит себя именно к ним) - давать ёмкие определения тому, для чего оного ещё нет. Однако, тут же ловишь себя на мысли - есть. Есть уже довольно прижившийся термин - смартфон. То есть "умный телефон". Где же грань между PDA (Personal Digital Assistant, "персональный цифровой помощник"), smartphone'ом, и, наконец, компьютером? Думаю, что отличия технических функций с течением времени будут всё меньше, пока... ну да это вроде не скоро будет :).

В настоящее время было бы логично различать такие устройство не по функциональным возможностям, а по их начальному назначению. То есть, если Handspring Visor был изначально КПК - то он им и остался, несмотря на появление GSM модуля расширения. А SL45 изначально телефон - отталкиваясь от этого и будем судить об остальных его возможностях. На сим считаю разбор терминологии законченным, переходим к разбору "полёта".

Скажу сразу - обзор вряд ли будет непредвзятым. Задолго до появления аппарата в розничной сети я видел анонсы - совсем не впечатлило. Нечто головастое на фото, непонятно зачем встроенная флэш память... Потом (много позже), у меня появилась возможность "поиграть" буквально в течении 2-3 часов с техническим семплом - образцом телефона, не предназначенным для продажи. То же двоякое впечатление - в "реале" понравился дизайн корпуса, однако огорчила тусклая подсветка. Телефон проигрывал mp3 файлы как хороший специализированный девайс - однако, довольно стандартная функция для телефонов 2G (второго поколения) - WAP браузер - не работала. Не работал также диктофон, то есть то, из-за чего многие его и ждали - всё-таки до 5 часов записи это не шутка. Дальше - больше. В Россию-мать завезли телефоны, предназначенные для продажи в несколько иных странах - в азиатских. Прошивка 3-ей версии, множество глюков, зачастую странная комплектация - 16 мегабайтная флеш-карта вместо 32 и т.д. Но - тут,как говорится, "поспешишь - людей насмешишь", так что данный обзор пишется по самому что ни на есть официально поставленному телефону, который и придется покупать российскому потребителю. Итак...

Упаковка

Упаковка очень хороша - на 5 с плюсом. Пластиковая, местами (через которые проглядывает начинка) прозрачная коробка запечатана наклейкой с голограммой - можете быть уверены, что вам не достался экземпляр с витрины, или, не дай Бог, б/у. Внутри обнаруживаем очень плотно скомпонованное содержимое - сам телефон, аккумулятор, настольный держатель (нет, не зарядник, т.к. он служит также для подключения к компьютеру), CD с всем необходимым ПО, наушники с микрофоном, сетевое зарядное устройство, кабель к ПК на COM порт и инструкции на нескольких языках, на русском инструкция такого же (высокого) качества прилагается отдельно. Всё достали, подключили в соответствии с инструкцией - продолжим.

Дизайн

Дизайн телефона (да-да, вещь весьма субъективная) - не более, чем приемлем. Я бы не сказал, что он "супер". Но и глаза не режет - факт. Для себя я бы определил так - недостатки дизайна для меня менее важны, нежели имеющиеся функции. Сюда же отнесём "янтарную", по определению Siemens'а, подсветку - жёлтую и тусклую. Но - отключаемую. А вот с эргономикой всё в порядке - пользоваться клавиатурой удобно, телефон приятно лежит в руке. Что касается конструкции - тут мы видим стандартную антенну, несколько отклоненную от вертикальной оси телефона, дабы снизить облучение головы пользователя, кнопка питания совмещена с функциональной клавишей отмены, что также скорее традиция - если производитель делает её отдельно (как Nokia или Motorola), или совмещено - то этой "линии партии" он придерживается и в дальнейшем. Аккумулятор крепится довольно надёжно, без люфта (как у Benefon Q изначально, или у Nokia 6*** со временем), СИМ карта располагается под ним. Крепление СИМа довольно нестандартное, автор, например, встречает такое впервые. Тут явно сказывается размер телефона - крепление довольно неудобное, но - максимально компактное. Думаю, из тех же соображений использована внешняя антенна - разместить внутреннюю просто негде. Карта памяти MMC вставляется сбоку, в крепёж, схожий с тем, который использовался на старых моделях сотовых (Motorola StarTac etc.). Конструкция довольно надёжная - вывалиться не должна. Микрофон расположен сзади, что не должно отразится на качестве речи, т.к чувствительность у современных микрофонов с запасом. В верхнем правом углу - глазок ИК порта. Заканчивая с конструктивом, отмечу следующее - в сервис центре Siemens предупреждают, что корпус телефона не разборный - т.е. любой внутренний ремонт влечёт за собой полную его замену - ещё один повод купить "белый" телефон с официальной гарантией.

Дисплей

Первое, что бросается в глаза - уже упомянутая жёлтая подсветка, которую, впрочем, можно отключить (скорее для экономии аккумулятора, нежели для эстетики). Ну да и ладно, вроде как телефон нацелен не на имиджевую категорию. Разрешение довольно высокое, есть возможность регулировки контрастности. Меню - основы всё те же, от 35ой серии. На любителя, конечно - на мой взгляд у Nokia удобнее и нагляднее. Но - вполне можно привыкнуть, и, возможно, даже полюбить :). В режиме ожидания на дисплее отображается индикатор уровня сигнала и заряда батареи (3 уровня, не информативно), название оператора, дата и время. Вместо оператора можно установить собственное лого - из комплекта телефона (записаны на MMC), или же ручного изготовления ;). Хранить их можно сколь угодно много в пределах объёма памяти. Идём дальше.

Телефонная книга

Тут мы уже переходим границы просто телефона, и затрагиваем область PDA - то есть цифрового "helper'a" (славное слово привёз нам из Америки тов. Кузин ;). Телефон может работать с телефонной книгой СИМ карты (что естественно), и с собственной - размещённой на MMC. Реализация на СИМ ничего нового нам не несёт, так что она обречена на копирование в память телефона (что он и предлагает сделать). Собственная же книга многофункциональна - на каждого абонента можно записать несколько телефонов (домашний / мобильный и т.д.), адрес физический, и, что становится всё более актуально - адрес электронный, то есть email и url. Всё это богатство при установке соответствующего ПО мы можем синхронизировать с ПК, а именно с Microsoft Outlook. Поддержки других программных пакетов, к сожалению, не предусмотрено. При синхронизации телефон нормально воспринимает кириллицу - а вот сам писать на ней не может, что для кого-то является минусом (не для автора). Сюда же добавлю и business card - ваша визитка того же содержания, которую вы можете передать собеседнику по SMS, или партнёру - по ИК порту компьютера. Удобно. Так же из дополнительных функций есть и голосовой набор - стандартная фича всех последних моделей, не совсем ясно лишь ограничение в 20 записей - можно было бы также использовать память MMC. Управление набором можно осуществлять кнопкой на микрофоне гарнитуры, подробнее о которой ниже. Помимо телефонного справочника в SL45 есть и органайзер - для записи напоминаний, встреч и т.д. Я вижу использование данной функции исключительно в связке с компьютером - набрали "план на завтра" в том же Outlook'е, синхронизировали с телефоном - и он вам напоминает. Эта же функция используется и для будильника (весьма продвинутого, надо сказать).

SMS

Работа с короткими сообщениями также реализована практически со всеми мыслимыми функциями. Небольшое отступление - на протяжении всего времени работы с телефоном меня не оставляло ощущение, что всё это где-то уже было. И действительно - SL45 собирает в себе практически все лучшие свойства аппаратов, с которыми мне приходилось работать. Многое пришло от Nokia, что-то - от Motorola, и т.д. В целом - очень положительно, не стоит пренебрегать полезной функцией лишь потому, что она уже реализована конкурентом. Да, я отвлёкся. Сообщения телефон может также хранить в памяти MMC - называется это архивом. Есть поддержка шаблонов, в которых есть поля для заполнения, есть поддержка словарей T9 (более подробное описание смотрите в предыдущих обзорах), которые можно подгрузить с карты MMC. Телефон спокойно принимает и просматривает сообщения на кириллице, однако писать таковые не умеет. Поддерживается несколько профилей настроек, что удобно при работе с различными SMSC, или, например, с ICQ. Подробнее о реализации смотрите в нашем FAQ по SMS

Чувствительность и звук

Сплошные похвалы - телефон не унаследовал основного недостатка 35ой серии - глухого звука динамика, характеризуемого пользователями "звук как из бочки". Чувствительность вполне на уровне, однако, до своего легендарного предшественника - модели S25 не дотягивает.

Игрища

Рассказ о "примочках" разделю на два условных раздела - по мелочи и глобальные. По мелочи - это 7 (семь !) встроенных игр, из которых мне особенно понравилась Move the Box - ностальгия по pacman'у сразу нахлынула (была такая игрушка в те времена, когда центральный процессор компьютера был в сотни раз слабее современных видео акселераторов). Есть часы/дата, секундомер, таймер, калькулятор (как обычно - неудобный), конвертор валют. В "мелочи" можно включить и WAP 1.1 - отлично работающий браузер, поддерживающий русский и не имеющий явных глюков (то есть я их не нашёл). Поддерживает несколько профилей настроек, сохраняет ссылки и т.д. В контексте применения отдельной памяти странно, что не реализовали отдельный email-клиент, как, например, у Sony Z5. Так что проверка почты - исключительно через WAP.

Диктофон

Теперь о глобальном. Начнём с диктофона. Ранее (до появления Siemens SL45), если покупателю был нужен хоть какой-то диктофон, он обращал своё внимание на модели фирмы Motorola, в которых память диктофона была на 3 минуты, то есть его можно было хоть как-то реально использовать. Те же сименсы с их 20 секундами записи не подходили по определению. Один мой знакомый даже изготовил из гарнитуры переходник к обычному диктофону - писать разговоры надо было, а готовых решений не было. Ситуация изменилась - SL45 позволяет записывать речь прямо на флеш карту, и ограничивается лишь её объёмом (на ту, что в стандартной поставке - максимум 5 часов (это на 32 мегабайта). Сеанс записи ограничен 20-ю минутами, хотя я не считаю это недостатком - редко приходится писать больше. Помимо очевидных функций записи разговора и коротких заметок, телефон может работать и как обычный диктофон - т.е. его можно положить на стол и записать, к примеру, переговоры. Все записи можно в дальнейшем записать на ПК.

MP3

Следующая важная функция - MP3 плеер, о которой производитель прямо-таки кричит с коробки телефона, что несколько странно - да, новинка, но ведь не основная область применения? Наверное, придётся несколько покритиковать. Что имеем в плюс - поддержка всевозможных битрейтов, вплоть до 256, поддержка vbr, довольно неплохое качество звука и достаточная максимальная громкость. Что не понравилось - нет поддержки ID тэгов, при воспроизведении файлов с vbr телефон нет-нет, да и зависнет. Ну и основное - всё те же наушники. Они несомненно хороши как гарнитура, однако я бы желал видеть такое решение - кабель до телефона, микрофон и пульт управления (а не одна многофункциональная кнопка), а в нём - разъём для стандартных "ушей". Тогда бы можно было бы подключить что-то "посерьёзнее". Ну и основной недостаток - очень медленная запись этих самых mp3 на флэш. Об этом ниже

Порты

Теперь рассмотрим одну из самых интересных функций - работу с компьютером. На компакт диске в комплекте, помимо всякой рекламной ботвы, есть две программы - одна предназначена для работы MMC, другая - для синхронизации данных. Ставим всё это богатство под Win2K - не вопрос, всё работает. Синхронизирует, MMC читает/пишет... Только вот делает всё это очень медленно! Ну очень. Ладно - проглотили то, что USB не сделали - ок. Но ограничить скорость передачи 9600 bps - это слишком. Mp3'шку в 5 мегов я заливал минут 20. Никакие настройки не помогли - это ограничение телефона. То же касается и ИК порта - телефон по нему может передать любой файл с карты памяти на другой телефон, или же на компьютер - однако скорость вас неприятно удивит. И опять же - ограничена телефоном, а не стандартом. Жаль. Возможно - в новых прошивках исправят ситуацию. С передачей данных проблем не возникло - телефон отлично работал как модем и по кабелю, и по ИК порту, в том числе с КПК (Cassiopea E-115)

Выводы

Итого. Мы имеем уникальный аппарат - есть возможность проигрывать музыку, записывать голос, WAP, и, основное - он может хранить файлы совершенно любого формата, что при условии наличия ИК порта на машине-адресате позволяет использовать его как дискету. Однако, есть и недостатки, самым существенным из которых я считаю низкую скорость обмена данными. Выбор за вами.


Глобальный хелп / Руссификация телефона

Прежде всего устанавливаем 56 прошивку в телефон.

Часто слышу на форуме крики о помощи пользователей телефона которые не знают куда девался их русский язык после перепрошивки, или почему же нет русского ввода в самой последней прошивке 56. Попробуем решить эти проблемы.

Русский язык в меню и т.п.

Для начала стоит заглянуть на свою карту памяти и узнать есть ли в папке Lanuage файл Russian.lng (Menu -> Surf/Fun -> Card-Explorer -> Language). Если есть тогда все хорошо, а вот если нет тогда стоит скачать вот этот архив и распаковать на карту памяти.

Теперь идем Menu -> Setup -> Device -> Lanuage. Теперь топаем вниз пока не появиться надпись Load, нажимаем ее и выбираем в списке Русский. Все нормально? Теперь вы можете выбрать этот язык в списке языков.

Русская раскладка

Топаем в этот раздел скачиваем патчи с раскладкой которая вам нужна, устанавливаем и живем припеваючи.


Глобальный хелп / "Снятия" скриншота с телефона Siemens SLxx

В последнее время на форумах многие юзеры задаются вопросом как сделать скриншот экрана SIEMENS SLxx. Прочитав огромное количество инфы я выкладываю вам проверенный и 100% вариант которым может воспользоваться любой осликовод.

Для начала вам стоит скачать програмку от великого RizaPN которая называется Capturer, а также патч который будет нужен для установки связи онлайн с телефоном (mamaich071.vkp).

Скачали прогу, установите патч. Все легко и просто если не нужно ничего кроме функции AT+GSN, тогда ставьте знаки коментария в пунктах 1,2,3,4,5. Не забудьте сделать копию флеша, на всякий случай... Установили? Поздравляю! Теперь вам доступна функция установки патчей в режиме он-лайн в V_Klay 2.3.2 и выше.

Теперь запускаем прогу и делаем следующие настройки: com порт - ваш; скорость - 19200; AT + CGSN Type - Type3. Теперь смело нажимаем кнопку Снятия скриншота с телефона Siemens SLxx не выключая телефон.

Снятия скриншота с телефона Siemens SLxx

Если сделано все правильно появится надпись "Connected".

Снятия скриншота с телефона Siemens SLxx

Теперь осталось самое малое нажать кнопку "Capture" и "Save" после того как загрузится изображение.

P.S. Не удивляйтесь если не получится сделать скриншот в Java, или если скриншот появится не такой какой он на телефоне, нажмите еще раз "Capture" и все придет в норму.


Глобальный хелп / Схемы(хэндсфри, com и usb кабели и т.п.)

Автор статьи - Werefox

Дата кабели

Теперь о кабеле для соединения телефона Siemens и компьютера. Схем существует множество и разных, смысл у них один.

Через COM порт

Рекомендую посетить страничку Виктора, на которой произведена огромная работа над конструированием различных Data-cable. Жаль, что не для Siemens, но если уж Вы сможете спаять Data-cable, то запросто разберётесь что в Siemens называется Rx и Tx. Пример работоспособной схемы Data-cable Siemens и распиновка разъёма есть ниже.

C помощью приведённой схемки, подаётся внешнее питание на выв16 схемы Data-cable, в этом случае разорвите проводник между выв16 микросхемы и выв4 телефона. Питающее напряжение подаётся либо с СОМ-порта компьютера, либо от внешнего источника питания . Если Вы используете МАХ232, то диод VD3 (он здесь просто "съедает" лишнее напряжение) не устанавливайте, а установите стабилитрон 3.3V м-ду общим и выводом, идущим к выв6 телефона (питание МАХ232 -5V, стабилитрон должен ограничить напряжение на выходе МАХ232).
Скачать документацию MAX3232, 78L05.

Простейшая, и при этом работоспособная схема Data-cable.

Настоятельно рекомендую питать микросхему от 4 ноги разъёма телефона (это будет наиболее корректно по отношению к входным уровням телефона). Если будете использовать этот шнур для прошивки, то питать следует от внешнего источника питания, но тогда необходимо позаботиться о стабилизации и выходном напряжении этого источника! Напряжение внешнего источника не должно превышать напряжение аккумулятора телефона (т.е. прим 3,6V). Изменения в схеме для питания от внешнего источника: необходимо разорвать соединение между выв.16 микросхемы и выв.4 разъёма. Напряжение внешнего питания подавайте на выв.16 микросхемы.

Через COM порт (фирменный кредл)

Некоторые умудряются их терять. Если повернуть разъёмы контактами к себе, то схема будет такой:

На сайте ValeraVi встретил интересную доработочку от Валеры. Найдете отличие - у Вас появится режим "AutoIgnition".

Через USB порт
(микросхемка USB to COM FTDI)

USB кабели эмулируют дополнительный СОМ-порт в системе и никак не увеличивают скорость записи-чтения ММС карты, флеша и т.п.

Схема кабеля USB <-> COM, предложенная мастером ValeraVi, слегка подкорректирована мною.

Это простой вариант USB дата-кабеля без зарядки. Сам его спаял и проверял на чтении/записи флеша - работает нормально. Дрова для такого кабеля, делающие в системе дополнительный СОМ порт лежат на сайте производителя микросхемы USB to COM FTDI: http://www.ftdichip.com/. Дрова там всякие: для 9x/Me, 2k/XP, для всего остального (Windows CE, Linux и т.п.) тоже есть... схема

Между USB и VCC микросхемы следует поставить дроссель.. или, как минимум, сопротивление, аналогичное R4.

Через USB порт
(микросхемка USB to COM CP2101)

И ещё одна, наиболее простая схема от ValeraVi

В ней встроено во внутрь все что снаружи у FTDI (даже ЕЕПРОМ встроен). Выходные уровни UART у этой микрухи 3.3 В. Размер микрухи 5x5x1mm, т.о. можно будет, наверно, ее (и 3 кондера) впихнуть в разъем сименса от гарнитуры. Драйвер здесь. Описание микросхемы здесь. И ещё: обе схемы "полнофункциональны", т.е. поддерживают все функции, которые можно предположить (data, GPRS, прошивка etc). Подходят для телефонов разработки Siemens х35, х45, х50 серий. Схема на FTDI может работать и с х25 серией. Для этого надо разорвать соединение выв.6-выв.13, выв.13 соединить с проводом питания. Немножко пояснения: выв.6 - выход встроенного стабилизатора напряжения 3.3В. выв.13 - вход, от которого зависит выходное напряжения. Какое напряжение на него подать, такое напряжение будет у уровня лог "1". Для х25 уровень лог "1" = 5В, для х35-х45-х50 лог "1" = 3.3В. Соединение выв.6-выв.13 обеспечивает выходные напряжения 3.3.В

Все для МР3

MP3 -стандарт сжатой записи звуковой информации, позволяет уменьшить размер аудиофайла в несколько раз, при этом не сильно потеряв в качестве, но наушники из комплекта телефона не в полной мере передают даже этот звук, поэтому многие ищут возможность использовать более качественные наушники. Один из способов подключения наушников сторонних производителей - переходник, схема которого приведена ниже. Подобный "девайс" выпускает известная фирма "Hama". Он хоть и надёжный, но стоит неоправданно дорого. Есть у переходника ещё один недостаток - теряется функция Handsfree... Самый, на мой взгляд, оправданный выход - в HandsFree использовать "уши" от чего-нибудь, звучащего лучше. Качества "ушей" от handsfree вполне хватает для прослушивания бытового приёмника или кассетного плейера (просто переставьте местами "уши" межу HandsFree и теми наушниками). Если Вы решите перепаивать "уши" от сторонних производителей (Sony Groove, Koss the plug...), то рекомендую аккуратно подцепить "ухо" ножом в верхней части. Как правило, наушники легко разбираются и перепаиваются. Не рекомендую резать провод наушников, ничего хорошего из этого не получается! :( В любом случае проследите за за полярностью включения, и за сопротивлением сторонних "ушей"(если сопротивление больше - звук будет тише, чем в прежних. Если намного меньше - можно перегрузить УМЗЧ телефона) !

Разъём для СЛИКа - от дохлого ЗУ, провод - четырёхжильный, экранированный, разъём для наушников - ... просто разъём для наушников. Провод чёрный, диаметром подобран так, что очень плотно входит в гофру разъёма наушников. В рзъём СЛИКа вставлена такая же гофра от разъёма для наушников. Сам провод длиной 3 см., длиннее делать - некрасиво смотрится.

соединение вывод 1 - вывод 7 обязательно! по этому соединению СЛИК определяет "хэндсфри". Предпочтительнее схема на рис.1, но она не подходит для наушников, больше для внешнего усилителя мощности. (звук - класс! при битрейте 192 не верится, что звуит телефон)

Если эта схема вам не понятна, то Уважаемый мастер ask перерисовал её в совсем упрощенном виде, понятней уже некуда:

Вот так выглядят преходники, изготовленные мной. Верхний - с "укороченным" разъёмом, сделан специально для нарукавной спортивной сумочки "Wester" (www.wester-connect.com), пришлось отказаться от фиксатора. Второй - обычный повседневный. Разъём телефона - от неисправного зарядного устройства. Провод - 4-х жильный, экранированный. Разъём наушников - просто китайский разъём. :)

Разъём

В SL45(i) выход второго канала снимается с вывода "2" разъёма. Соединение выводов 1 и 7 сообщает телефону о хэндсфри с внешней кнопой РТТ (РТТ включает handsfree коротким соединением вывода 1 с выводом. 8). А если соединить выводы 1 и 8, то телефон распозает это как "автоподнятие" (необходимо включить в телефоне функцию "использование в автомобиле")

Хэндсфри

Cхема HandsFree Siemens SL45. В них используется 6-ти жильный провод в сдвоенном рукаве, то есть в каждом рукаве проложено по три провода, что само по себе редкость. "Уши" используются обычные, плейерные.

Фонарик

Китайские разъёмы просто созданы для 8мм светодиодов!J. Синий свет. Очень ядовитый... Собаки почему-то не любят его.


Глобальный хелп / SMS просто и легко - советы sms писателям

Данная статья посвещена прежде всего тем кто часто обмениваеться sms с другом (подругой), и просто будет полезна всем кто хочет узнать несколько фичей в телефоне.

Для начала откроем Меню >> Сообщения >> SMS >> Настройки >> SMS

рисунок № 1

Теперь вашему взору открываются следующие варианты:

  • сервис. центр - здесь вводится номер центра через который проходят все sms сообщения вашего оператора. При подключения сим-карта скорее всего уже будет иметь настроеный номер, если нет то свяжитесь со справочной оператора и задайте этот номер.

  • Получатель - А вот эта функция очень полезно! Фишка в том что если вы часто посылаете sms на один и тот же номер, то здесь вы можете ввести его!!! И номер автоматически будет вставляться как только вы нажмете "передать".
  • срок действ - Выставляем "максимум".
  • отчет об отп - при доставке sms или ее недоставке(ошибке и т.п) присылается ответное сообщение.
  • непоср. отв. - фишка которая ставила под сомнение функцию "Ответить" при чтении полученной sms на оСЛИКе. Ведь фишка в том что при получении sms вы получается его через серевисный центр отправителя, и когда вы нажимаете ответить то соответственно берется номер сервисного центра из sms. Поставив галочку в любом случае будет использоваться только номер вашего сервисного центра.

    • Перепечатка материалов разрешается, только после письменного разрешения администратора сайта (e-mail).


Глобальный хелп / Замена картинок с помощью Siemens Picture Change 2

Автор статьи - Franky (franky@siemens-sl45.net)

Данная программка предпочтительнее для изменения графики в телефоне Siemens чем предыдущая – FFmod. Огромный плюс в том что она может существенно облегчить работу новичкам и профессионалам. Новичкам понравится то, что загрузка измененной графики происходит непосредственно через V_klay в виде патча, который можно откатить. А профессионалы смогут делиться своими патчами с друзьями.

Программка легка в использовании т.к. в ней присутствует русский интерфейс. Итак, начнем.

Активация Java на SL42/SL45/SL45i

1. Считайте фуллфлеш телефона
2. Загрузите фуллфлеш кнопкой "Открыть Флеш".
Пункт Изменение картинок – картинки из всего флеша
Пункт Редактор главного меню – здесь можно поменять рисунки батареи, антенны и профиля
3. Для того чтобы изменить рисунок нажмите по нему правой кнопкой в списке либо по окну предосомотра. 4. Нажимайте load 1bit picture from file и указывайте рисунок с диска
5. После изменения нужных рисунков нажимаем «Сохранить патч как» и применяем в V_klay.


Глобальный хелп / Увеличение громкости спикера на sl45i

Автор статьи - VITb+OK. При содействии SERJINHO.

Для начала не большой намёк. Возьмите в руки оСЛИКа и засуньте его себе э…(шутка :-). Вот и включите проигрывание мелодий, а теперь зажмите пальцем маленький чёрный прямоугольничек находящийся на верхней части телефона между антенной и IRDA. Ну что прикололись, звук стал громче - вот это мы и используем.

Этот документ для тех у кого второй случай (что естественно). Итак для начала необходимо разобрать телефон (что то же естественно). Сразу оговорюсь, что после того как хотя бы один раз вскроешь оСЛИКа, две половинки корпуса уже не будут так плотно прилегать друг к другу. Короче говоря корпус практически одноразовый. После вскрытия тела вы легко обнаружите вибру - она находится вверху на задней стенке (см. рисунок).

Для начала разберём телефон. Потом надо отделить саму плату от передней части корпуса. Крепится она на маленьких белых зажимах в верхней части. Начинать советую с того боку, где находятся кнопки управления МР3. Итак, справившись с этим, мы обнаружим сам спикер. Собственно это даже не спикер, а защитный чехол, спикер находится внутри него. Аккуратно отцепляем его от корпуса (делать это надо потянув за тот самый прямоугольничек вверху спикера, см. рисунок).

Посмотрев повнимательней на него можно обнаружить что, он не сплошной этот нарост на спикере и как бы продавливается. На самом деле там небольшое отверстие, заклеенное какой липучкой. Именно через него и выходит звук. Теперь остаётся лишь затолкав в эту нишу что-то и весь звук будет идти вперёд, а не куда-то вверх. Лично я запихпул туда кусочек липучки типа такой на которой держится стёклышко телефона. Будьте осторожней не протолкните это "что-то" слишком глубоко, чтобы оно не повредило спикер; и не пытайтесь заливать клей. Всё, теперь только остаётся только просверлить 2-4 лишние дырочки в корпусе и наслаждаться.

Лично я почувствовал реальную разницу. А лучшей способ - это взять два оСЛИКа: одной простой, один модернизированный и включить одновременно одну и ту же мелодию. Спасибо за внимание. Удачи всем ослиководам.


Глобальный хелп / Ремонт вибры на sl45i

Автор статьи - VITb+OK. При содействии SERJINHO.

Чаще всего причиной неисправности вибры являются две причины:

  1. Вибра вообще сгорела (в этом случае можете дальше не читать).
  2. Эксцентрик (это такая половинка цилиндра) - вибратора при работе за что-то цепляется

Этот документ для тех у кого второй случай (что естественно). Итак для начала необходимо разобрать телефон (что то же естественно). Сразу оговорюсь, что после того как хотя бы один раз вскроешь оСЛИКа, две половинки корпуса уже не будут так плотно прилегать друг к другу. Короче говоря корпус практически одноразовый. После вскрытия тела вы легко обнаружите вибру - она находится вверху на задней стенке (см. рисунок).

Теперь надо определить за что цепляет эксцентрик. Тут опять два варианта: либо за корпус (что более приятно), либо за плату(что хуже). Если он цепляет за корпус, то нужно визуально определить где именно и просто подпилить это место.

Со вторым вариантом сложнее. Здесь я предлагаю такое решение: нужно вибру вытащить и выкинуть(шутка конечно:-). Так вот вытащить и просто перевернуть и поставить на то же место только металлическим креплением в другую сторону. А что б она не болталась и не выскочила укрепить чем-то (желательно чтоб это "что-то" могло аммортизировать) и приклеить сверху кусочик скотча. Лично я использовал кусочек клейкой резины, которая идёт в комплекте с новым корпусом. Наклейте столько что бы корпус плотно прижимал вибру, но при этом мог свободно закрыться. Спасибо за внимание. Удачи всем ослиководам.


Глобальный хелп / Проблемы при установке патчей

Мастер ValeraVi предложил программу, которая является самой удобной и универсальной программой на сегодняшний день! Эта программа позволяет применять патчи в формате .vkp, читать-писать FullFlash и EEPROM для бэкапа, имеет встроенный редактор раскладки клавиатуры, позволяет работать как с файлом фулфлеша, так и с телефоном непосредственно. Поддерживает все наиболее используемые форматы файлов-патчей, в.т.ч. и *.crk, предложенный ранее. Рассказывать, как применять патчи через эту программку я не стану т.к. в ней поставляется очень неплохой хелп. Остановлюсь лишь на нескольких замечаниях, а также проблемах которые могут возникнуть при установке патчей в частности различные всплывающие окна с замечаниями и т.п.

Проблема № 1

Проблемы при установке патчей

Суть проблемы в том, что в одной из строк, а может и во всех, отсутствуют данные о старом значении. Объясняю: програмка V_Klay ставит патчи в формате
адрес: старые_данные новые_данные
0E5267: 45E0 2345

Но если "старые_данные" непрописаны, тогда патч невозможно откатить. Конечно в основном все патчи поставляются с прописанными "старыми данными". Если они не прописаны значит либо автор патча не потрудился их узнать, либо их нельзя определить (они хаотично меняются).

Приведу рецепт решения данной проблемы.

  1. Для начала вам понадобится програмка Full Flash Comparer 2.
  2. Делаем бэкап(обязательно "свежий"), и создаем его копию. Теперь скопируйте их в отдельную папку. Для удобства назвать файлы original.bin и patched.bin.
  3. Открываем в V_Klay патч. Далее в верхнем левом углу выбрать в поле "Работать с:" вариант "Файлом части флеш" и указать путь к файлу patched.bin и патчим его тем заветным патчем на все вопросы отвечая "Да".

    4. Проблемы при установке патчей

  4. Теперь запускайте ту самую прогу Full Flash Comparer 2

    Проблемы при установке патчей

    В поле "Original file" указываем путь к файлу orginal.bin
    В поле "Patched file" указываем путь к файлу patched.bin
    Нажимаем кнопку "Compare" после этого прога сканирует два флеша и ищет в них различия по адресе во флеше и дает нам то, что нам и нужно! правильный патч в .vkp(старые_данные новые_данные).
    Теперь вы можете сохранить различия в .vkp (кнопка Save -> .vkp) или скопировать в буфер обмена, а потом вставить в V_Klay.

Проблема № 2

Проблемы при установке патчей

Вернемся опять к наше формуле адрес: старые_данные новые_данные. Данное предупреждение указывает на то, что старые_данные несоответствует значению в вашем фуллфлеше телефона. Т.е при откате патча возможны неприятные последствия.

Обычно такие ошибки появляются после применения патчей старых версий (при установке "Выбираемое лого Оператора ver.3" поверх "Выбираемое лого Оператора ver.2"); после применения патчей изменяющих одинаковые области данных во флеше("Мидлет при заблокированной Клавиатуре" и "Выбираемое Лого Оператора ver.4").

Я рекомендую записывать в отдельную папку на диске все установленные патчи AS IS т.е. со всеми вашими изменениями (знаки комментария). А перед установкой патчей внимательно читать инструкции, там обычно указано какие-версии патчей следует откатить. В дальнейшем это поможет вам избежать появления таких окон.

Проблема № 3

Проблемы при установке патчей

Данная проблема полная противоположность проблеме № 2. Разница лишь в том здесь новые_данные несоответствует значению в вашем фуллфлеше телефона. Т.е. рекомендации те же что и в предыдущем параграфе.

Заключение

В заключении могу лишь сказать: если вы так и не смогли найти ответа на ваш вопрос, воспользуйтесь схемой описаной в первом параграфе. Считываете фуллфлеш, делаете его копию, применяете патч, сравниваете два фуллфлеша, различия записываете через V_Klay на ваш телефон.


Глобальный хелп / Конвертирование vmo в wav и обратно

Итак что такое vmo - это кодированый формат диктофона оСЛИКа. Которой позволяет сжать wav файл примерно в 10 раз! Вот этим мы и займемся. В смысле прослушиванием записей диктофона на компе, и записей wav (предварительно сконвертированных) в телефоне.

Для начала вам понадобиться данная программа

Теперь вам нужно найти на телефоне ваши записи дктофона, он лежат в папке Voice memo на карте памяти. Скопируйте их в ту папку в которую вы разархивировали прогу (так удобнее). А теперь два способа конвертации.

Способ легкий

Заходим в папку с прогой и запускаем файл W_V_En.exe.

рисунок № 1

Проще програмки и не придумаешь! Выбираем в которую сторону конвертировать
Vmo convert to Wav = Vmo в Wav
Wav convert to Vmo = Wav в Vmo
А далее собственно в окошке ниже выбираем сам файл и нажимаем конвертировать (CONVERT)

После нажатия кнопки, появиться черное окошко и будет "висеть" в зависимости от размера файла.

Способ потяжелее

Последнее время на форумах появляются сообщения пользователей о том что у них после нажатия кнопки (CONVERT), ничего не происходит. Возможно в папке отсутствуют файлы Vmo2Wav.exe и Wav2Vmo.exe. Если все на месте идем дальше, попробуем безотказный способ.

Для работы нам понадобиться любой файловый менеджер к примеру Total Commander. Открываем в нем папку с нашей заветной программой и пишем:
Vmo2Wav.exe xxx.vmo, где файл xxx.vmo который мы хотим сконвертировать в wav;
Wav2Vmo.exe xxx.wav, где файл xxx.wav который мы хотим сконвертировать в vmo;
нажимаем Enter и ждем. В результате появиться файл с таким же именем, но в другом формате

рисунок № 2
рисунок № 3


Глобальный хелп / Записанный ответ

Многие владельцы телефона даже и не догадываются о такой прекрасной функции телефона как «Записанный ответ». В чем его суть? Допустим у вас сейчас лекция или важная встреча, но которой вы не можете поднять трубку, но вы бы хотели сообщить звонившему через сколько он сможет перезвонить или другую информацию. Для этого в оСЛИКе и предусмотрена данная функция называемая «Записанный ответ»

Попробуем ее настроить. Зайдите в Меню>>Органайзер>>Записан. ответ. Вам отобразится надпись «новый». Нажимайте ее делайте запись и сохраняйте ее под каким-нибудь именем. Теперь она есть в списке выбора и вы можете ее выбрать. При поступлении звонка нажав кнопку диктофона, активизируется запись и циклически повторяется пока вы не положите трубку, или ее не положит звонивший.

P.S. Вы можете поднять трубку если ее не бросил звонивший. Для этого я рекомендую сделать следующую запись: «Извините, но я не могу поднять трубку в данный момент подождите секундочку»

P.P.S. За устнановленное соединение, с того момента как вы активировали «Записанный отвте», вам будет начисляться плата исходя из тарифов вашего оператора за входящие звонки. А позвонившему по тарифу за исходящие звонки.


Глобальный хелп / Надпись «Wrong Software» и ее исправление.

Автор статьи - Franky (franky@siemens-sl45.net)

Чаще всего эта надпись появляется после смены прошивки или после заливки чужого фуллфлеша.

Для реанимации телефона, вам понадобится программка Siemens Unlock 5.1.

Запускаете программку и выбираете модель телефона – SL45. Теперь вам нужно зайти в пункт «СЕРВИС» и выбрать «Раблокировать, Сменить IMEI»

Надпись «Wrong Software» и ее исправление.

Нажимаем кнопку «Разлочить» и вставляем выключенный телефон в стакан или подключаем к нему дата-кабель. На экране появится непонятные надписи и теперь вам нужно вписать свой IMEI номер, найдете его либо на гарантийном талоне или на корпусе телефона под батарейкой. Вписываем его без последней цифры. Нажимаем «Сменить».

Телефон готов к работе!!!


Глобальный хелп / Снятие дисплея и клавиатуры

Автор статьи - Sektor (sektor@butovo.com)

Перед началом всех действий от вас требуется телефон уже без корпуса.

Поехали, кладём слика экраном вниз, отклеиваем коричневую штуку, ту которая с 2 желтыми кружками (см рис. 1). Далее отцепляем от защёлок ту часть клавы где кнопки плера (см рис. 2).

рисунок № 1 рисунок № 2

Далее АККУРАТНО отцепляем правую защёлку дисплея (рис3) потом левую ( рис4), "открываем" дисплей.

рисунок № 3 рисунок № 4

Далее мы видим 2 защёлки (рис5) возможно на них будет прозрачная наклейка , думаю что это что-то вроде пломбы, небоимся и отклеиваем её. Очень окуратно отщёлкиваем эти 2 защёли , приподнимая коричнивую планку вверх(рис5).

рисунок № 5

Вы уже близки к победе , осталось снять защёлки на на клавиатуре (рис 6,7)

рисунок № 6 рисунок № 7

P.S. Советую вам обзавестись тонким двустороним скотчем , например чтобы обратно приклеить коричневую штуку, ту которая с 2 желтыми кружками (рис 1)


Глобальный хелп

В данном документе публикуются темы которые часто приводят в замешательство новичков, при повседневной работе с телефоном. И не только... В частности есть темы которые будут полезны при смене прошивки, установке поддержки Java (ионизация), активировании NetMonitor, установке патчей.

  • Бэкап и заливка фуллфлеша
  • Смена прошивки телефона
  • Надпись "Wrong Software" и ее исправление
  • Активация Java на SL42/SL45/SL45i

  • Форматирование MMC после смены прошивки
  • Структура стандартного контента карты MMC

  • Замена картинок с помощью FFmod
  • Замена картинок с помощью Siemens Picture Change 2

  • Проблемы при установке патчей

  • Включения NetMonitor
  • Калибровка аккумулятора

  • Записанный ответ
  • Восстановление Адресной книги
  • Различия прошивок 43 - 56 в телефонах SL42, SL45, SL45i

    • Добавлено 8.08.2004
  • Схемы(хэндсфри, com и usb кабели и т.п.)
  • "Секретные" сочетания клавиш

    • Добавлено 30.08.2004
  • Ремонт вибры на sl45i
  • Увеличение громкости спикера на sl45i
  • Бэкап и заливка фуллфлеша при помощи FREIA

    • Добавлено 19.09.2004
  • "Снятия" скриншота с телефона Siemens SLxx

    • Добавлено 30.09.2004
  • Снятие дисплея и клавиатуры
  • Полезные советы по работе аккумулятора

    • Добавлено 06.10.2004
  • SMS просто и легко - советы sms писателям
  • Конвертирование vmo в wav и обратно
  • Руссификация телефона
  • Обзор телефона SIEMENS SL45 от SHERIF'a